PDA

View Full Version : Installation


Taccs
06-24-2007, 05:24 AM
Hey, im usuing the newest copy of Ubuntu Feisty. I'm a complete beginner to linux and for some reason I seem to be the only person who can't even install the game, now it's probably a really silly reason but here is what I try to do, and what happens:

Download rolauncher.tar.gz from website, unpack and chmod +x the rolauncher file.

After that I ./rolauncher and everything goes fine, I accept the licensing agreement and then takes me to a page that says enter account name and password etc so I do that and hit entrar button and i get an error in the terminal saying Segmentation Error (core dumped) nothing else.

Also i'm behind a router but i can sudo apt packages fine :S im so lost

ArcticWolf
06-24-2007, 05:41 AM
Hey, im usuing the newest copy of Ubuntu Feisty. I'm a complete beginner to linux and for some reason I seem to be the only person who can't even install the game, now it's probably a really silly reason but here is what I try to do, and what happens:

Download rolauncher.tar.gz from website, unpack and chmod +x the rolauncher file.

After that I ./rolauncher and everything goes fine, I accept the licensing agreement and then takes me to a page that says enter account name and password etc so I do that and hit entrar button and i get an error in the terminal saying Segmentation Error (core dumped) nothing else.

Also i'm behind a router but i can sudo apt packages fine :S im so lost

Try downloading the files again.

(And I didn't have to chmod the files)

Taccs
06-24-2007, 05:48 AM
to be honest man i've redownloaded these files about 4 times and 2 different ways, still nothing

ArcticWolf
06-24-2007, 05:58 AM
to be honest man i've redownloaded these files about 4 times and 2 different ways, still nothing

It's not an internet thing, so we can discard any connection problem...

It is, in fact, one of the files the game uses... The problem here is to know which of them. Can you post the error_backtrace and error files on the live folder of the game (if there are any of them), please?

Taccs
06-24-2007, 06:00 AM
that's the thing there are none, here is all it has in the live folder:

System.nfo:
[CPU]
- Vendor Name: GenuineIntel
- Model Name: INTEL Pentium-III
- Family: 6
- Model: 8
- Stepping: 6
- Feature: 3
- Os Support: 0
- Checks: 15

[GPU]
- OpenGL Support: 0
- Shader Model: Fixed Pipeline
- GPU Info:

[Distribution]
Distributor ID: Ubuntu
Description: Ubuntu 7.04
Release: 7.04
Codename: feisty

ArcticWolf
06-24-2007, 06:03 AM
Don't you get to a screen where it has the following options? Salir, Opciones, Jugar?

Taccs
06-24-2007, 06:05 AM
No, the first post states i don't even install the game, i just download the tar unpack it run ro launcher it tells me to accept a license agreement so i do that then enter password and username so i do that hit entrar and thats it crash segmentation error and nothing is installed

Myxir
06-24-2007, 03:58 PM
[GPU]
- OpenGL Support: 0

Doesn't that mean that there is no support for opengl??
What Graphic Card are you using and which drivers do you have installed?

dejan
06-24-2007, 08:16 PM
I get the same (Segmentation fault) after the login dialog too, on my laptop with Fedora 7.


[dejan@mrak regnum]$ ./rolauncher
Segmentation fault


GDB:

.
.
.
[New Thread -1211081840 (LWP 2371)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Detaching after fork from child process 2373. (Try `set detach-on-fork off'.)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208846112 (LWP 2367)]
0x00f5b370 in ?? ()
(gdb) bt
#0 0x00f5b370 in ?? ()
#1 0x0512a7f8 in ?? () from /usr/lib/libGL.so.1
#2 0x051262ed in ?? () from /usr/lib/libGL.so.1
#3 0x05127fda in glXChooseVisual () from /usr/lib/libGL.so.1
#4 0x0807ddb7 in gtk_combo_box_entry_new ()
#5 0x0807e83e in gtk_combo_box_entry_new ()
#6 0x0808958b in gtk_combo_box_entry_new ()
#7 0x0805dcb3 in gtk_combo_box_entry_new ()
#8 0x08064a69 in gtk_combo_box_entry_new ()
#9 0x08067b71 in gtk_combo_box_entry_new ()
#10 0x08101ffe in gtk_combo_box_entry_new ()
#11 0x0805c52e in gtk_combo_box_entry_new ()
#12 0x006b2f70 in __libc_start_main () from /lib/libc.so.6
#13 0x0805c361 in gtk_combo_box_entry_new ()


Since ATI did not yet released GNU/Linux drivers for kernel 2.6.21 i am forced to use Mesa3D - all other games that I play (Eternal Lands, Glest, Warzone2100, Globulation2, ...) work fine.

wakim42
06-24-2007, 10:29 PM
Mesa3D dont support openGL so you have to use fglrx (ati proprietary driver) and yes the last one work for 2.6.21 (at least it works for me)

Froste
06-24-2007, 11:39 PM
Mesa3D dont support openGL so you have to use fglrx (ati proprietary driver) and yes the last one work for 2.6.21 (at least it works for me)

Actually mesa is opengl using the software renderer

dejan
06-25-2007, 01:28 AM
With all respect sir/madam, You have no idea what Mesa3D is, if You claim it does not support OpenGL... Please read more about this popular open-source project on http://www.mesa3d.org . Latest Mesa3D supports OpenGL 2.1.

@Froste Mesa3D also has hardware acceleration for numerous graphics cards. (From mesa3d.org: The DRI hardware drivers for the X.org server and XFree86 provide hardware accelerated rendering for chips from ATI, Intel, Matrox, 3dfx and others on Linux and FreeBSD.)

Froste
06-25-2007, 02:08 PM
Of course it has hardware acceleration too. I thought this was implied.

leptom
06-25-2007, 04:46 PM
You need mesa 6.5.3 to play.Ubuntu, for example, have mesa3d 6.5.2.

Regards!

Myxir
06-25-2007, 07:38 PM
glxinfo | grep rendering

in your terminal and you wil see if there is 3D support.

toxigenicpoem
06-25-2007, 07:39 PM
Yes you will need to install the latest ATI drivers, and 8.37 is working for the latest Kernel update.

dejan
06-28-2007, 11:05 PM
Guys... there is NO need for proprietary ATI driver if you have Mesa3D because, as we said in previous posts, Mesa3D offers ACCELERATED (HARDWARE) GRAPHICS (OPENGL) !!!!!

For those who after all we said recommended to execute "glxinfo | grep rendering":

[root@mrak ~]# glxinfo | grep rendering
direct rendering: Yes


Furthermore:

[root@mrak ~]# glxinfo | grep OpenGL
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R300 20060815 AGP 1x x86/MMX/SSE2 TCL
OpenGL version string: 1.3 Mesa 6.5.2
OpenGL extensions:


With ALL DUE respect, please stop talking about Mesa if you did not try it, or have no clue what it is, or have just heard about it.

For those who know what I am talking about: Could it be that this problem occurs because installer needs some specific VISUAL which is perhaps not supported here?

arlick
06-29-2007, 12:15 AM
Guys... there is NO need for proprietary ATI driver if you have Mesa3D because, as we said in previous posts, Mesa3D offers ACCELERATED (HARDWARE) GRAPHICS (OPENGL) !!!!!

For those who after all we said recommended to execute "glxinfo | grep rendering":

[root@mrak ~]# glxinfo | grep rendering
direct rendering: Yes


Furthermore:

[root@mrak ~]# glxinfo | grep OpenGL
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R300 20060815 AGP 1x x86/MMX/SSE2 TCL
OpenGL version string: 1.3 Mesa 6.5.2
OpenGL extensions:


With ALL DUE respect, please stop talking about Mesa if you did not try it, or have no clue what it is, or have just heard about it.

For those who know what I am talking about: Could it be that this problem occurs because installer needs some specific VISUAL which is perhaps not supported here?

i know that u need OpenGL 2.1 version, surak said that some weeks age in the spainsh forum

leptom
06-29-2007, 01:15 AM
With Mesa3D 6.5.3 you can play Regnum online. I play with it.

Sorry for repeat me.

Regards!

dejan
07-05-2007, 03:59 PM
Thanks guys for some usefull information - I'll just download Mesa3D 7.0 and build it here until RPMs come.

Kind regards!