English

Go Back   Champions of Regnum > English > Technical Support > Linux

Linux Technical issues under Linux platform

Reply
 
Thread Tools Display Modes
Old 11-12-2011, 09:32 AM   #1
aurei
Pledge
 
Join Date: Nov 2011
Posts: 2
aurei is on a distinguished road
Default Weird graphics on intel integrated

I'm running Ubuntu 11.10 and I managed to install the s3tc library, but both with faking the support for it and having the actual support the graphics are really weird. All the characters and some of the environment have these "see-through pixels"

http://imageshack.us/photo/my-images...111211135.jpg/

I'm trying to run the game on intel integrated graphics (i5-2410M), but I also have a NVidia gt540m, but when I try to run it with ironhide i get the following error:

Code:
Saving backtrace to crash_backtrace_8959.log
Got SIGSEGV (segmentation fault)
crash_backtrace_8959.log:
Code:
./game(_ZN10ClientBase14save_backtraceEv+0x5f) [0x6688ff]^@
./game(_ZN10ClientBase12client_crashEi+0x8) [0x668d28]^@
/lib/x86_64-linux-gnu/libc.so.6(+0x36420) [0x7fb536366420]^@
./game(glBindFramebufferEXT+0) [0x14083f0]^@

Help for either the intel graphics problem or the nvidia one (or both) would be greatly appreciated.
aurei no ha iniciado sesión   Reply With Quote
Old 11-14-2011, 12:47 PM   #2
DINAMIK
Count
 
DINAMIK's Avatar
 
Join Date: Jan 2010
Posts: 1,676
DINAMIK is on a distinguished road
Default

I suggest you to deactivate the intel graphic card and use the nvidia one all the time. that service provided by your notebook (I guess is called Optimuz) does not have good support on linux system even there's no driver that can handle it yet. maybe by deactivating the intel card in your bios properties the regnum can runs better. I can't provide you with a better solution for now
__________________
DINAMIK´s guides
Desconexiones / Mejores fps
GUARDIANES DEL INFIERNO
DINAMIK no ha iniciado sesión   Reply With Quote
Old 11-14-2011, 03:46 PM   #3
aurei
Pledge
 
Join Date: Nov 2011
Posts: 2
aurei is on a distinguished road
Default

Unfortunately my laptop model does not offer such a BIOS option.
aurei no ha iniciado sesión   Reply With Quote
Old 11-14-2011, 05:08 PM   #4
SilverHaven
Initiate
 
Join Date: Apr 2011
Posts: 179
SilverHaven is on a distinguished road
Default

I noticed glitches (messed polygons, blinking textures) in RO after upgrading intel-dri to 7.11, so I had to downgrade back to 7.10.3. Reported bug here. without reply though. I use Arch Linux and intel-dri is part of mesa. Check your driver version and try with 7.10 if ubuntu contains 7.11.
SilverHaven no ha iniciado sesión   Reply With Quote
Old 11-14-2011, 05:52 PM   #5
Awrath
Master
 
Awrath's Avatar
 
Join Date: May 2010
Location: England
Posts: 439
Awrath is on a distinguished road
Default

Quote:
Originally Posted by Jaroslav View Post
I noticed glitches (messed polygons, blinking textures) in RO after upgrading intel-dri to 7.11, so I had to downgrade back to 7.10.3. Reported bug here. without reply though. I use Arch Linux and intel-dri is part of mesa. Check your driver version and try with 7.10 if ubuntu contains 7.11.
Same problem same solution! Pity there's been no response on the bug report.
Awrath no ha iniciado sesión   Reply With Quote
Old 11-16-2011, 05:26 PM   #6
DINAMIK
Count
 
DINAMIK's Avatar
 
Join Date: Jan 2010
Posts: 1,676
DINAMIK is on a distinguished road
Default

xorg ppa has the xorg 7.12, i dont remember what is the base version
__________________
DINAMIK´s guides
Desconexiones / Mejores fps
GUARDIANES DEL INFIERNO
DINAMIK no ha iniciado sesión   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
NGD Studios 2002-2013 © All rights reserved