Go Back   Champions of Regnum > English > Technical Support > Linux

Linux Technical issues under Linux platform

Reply
 
Thread Tools Display Modes
Old 12-20-2018, 07:40 PM   #1
platyna
Initiate
 
Join Date: Feb 2009
Location: Poland
Posts: 233
platyna is an unknown quantity at this point
Default Segmentation fault (core dumped)

I have a following problem:

[platyna@boadicea regnum]$ ./rolauncher
Segmentation fault (core dumped)

Fedora 29 with newest updates, NVdia Quadro card.
__________________
Syrtis, Horus: Platyna (Conjurer), Platyna Ahn (Warlock), Platyna Ida (Hunter), Platyna Ira (Barbarian)
platyna no ha iniciado sesión   Reply With Quote
Old 12-20-2018, 11:03 PM   #2
schachteana
Master
 
schachteana's Avatar
 
Join Date: Mar 2011
Posts: 421
schachteana is on a distinguished road
Default

C++ in a nutshell
schachteana no ha iniciado sesión   Reply With Quote
Old 12-31-2018, 01:10 PM   #3
_Enio_
Marquis
 
_Enio_'s Avatar
 
Join Date: Aug 2007
Location: Germany
Posts: 1,851
_Enio_ will become famous soon enough
Default

Hah platyna, i remember you from long ago To the issue at hand - it could well be some incompatile library version.


I suggest to install gdb, the gnu debugger (yum install gdb) and start rolauncher with it, it might be able to give some insight in where exactly it is crashing.


Once gdb is installed, naviage to the regnum directory and launch a console, then issue
Code:
gdb ./rolauncher
This will bring you inside the gdb console ready to debug. now just type run or r to get rolauncher executed with the debugger attached.
Once it crashed it will pause and you can issue more commands, i suggest to issue
Code:
bt
to get a backtrace on the function calls - paste the output here, it might give a hint which library is the culprit.


Exit gdb with the command
Code:
quit
Good luck and a happy new year.
__________________
Fix the Marksman subclass: Suggestion
_Enio_ no ha iniciado sesión   Reply With Quote
Old 10-12-2019, 06:28 AM   #4
_Lutz_
Pledge
 
Join Date: Jan 2011
Posts: 10
_Lutz_ is on a distinguished road
Default

I have same issue with fedora 30 (kernel 5.2.18-200.fc30.x86_64 #1 SMP Tue Oct 1 13:14:07 UTC 2019)

GNU gdb (GDB) Fedora 8.3-6.fc30
Copyright (C) 2019 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/local/regnum/rolauncher...
(No debugging symbols found in /usr/local/regnum/rolauncher)
(gdb) r
Starting program: /usr/local/regnum/rolauncher
[New LWP 6195]
[LWP 6195 exited]
[New LWP 6196]
[New LWP 6197]
[New LWP 6198]
[New LWP 6199]
[New LWP 6200]
[LWP 6200 exited]

Thread 1 "rolauncher" received signal SIGSEGV, Segmentation fault.
0x000000084d564d08 in ?? ()
(gdb) bt full
#0 0x000000084d564d08 in ?? ()
No symbol table info available.
#1 0x0000000000aa8615 in ?? ()
No symbol table info available.
#2 0x00000000016deb00 in ?? ()
No symbol table info available.
#3 0x00000000012d4460 in ?? ()
No symbol table info available.
#4 0x00000000016deb00 in ?? ()
No symbol table info available.
#5 0x00000000012cf550 in ?? ()
No symbol table info available.
#6 0x000000000000009c in ?? ()
No symbol table info available.
#7 0x0000009c0001faa4 in ?? ()
No symbol table info available.
#8 0x0000000000000000 in ?? ()
No symbol table info available.
(gdb) info threads
Id Target Id Frame
* 1 LWP 6185 "rolauncher" 0x000000084d564d08 in ?? ()
3 LWP 6196 "rolauncher" 0x00007ffff7d910a5 in ?? ()
4 LWP 6197 "gmain" 0x00007ffff71dbae7 in ?? ()
5 LWP 6198 "gdbus" 0x00007ffff71dbae7 in ?? ()
6 LWP 6199 "pool-rolauncher" 0x00007ffff71e11fd in ?? ()
(gdb) thread apply all bt full

Thread 6 (LWP 6199):
#0 0x00007ffff71e11fd in ?? ()
No symbol table info available.
#1 0x00007ffff7ad2f76 in ?? ()
No symbol table info available.
#2 0x000000000000070c in ?? ()
No symbol table info available.
#3 0x000000000fb656b6 in ?? ()
No symbol table info available.
#4 0x000000000000000e in ?? ()
No symbol table info available.
#5 0x000000003b9ac622 in ?? ()
No symbol table info available.
#6 0x00007fffe62d0bb0 in ?? ()
No symbol table info available.
#7 0x5ac9915a61af7400 in ?? ()
No symbol table info available.
#8 0x0000000000000001 in ?? ()
No symbol table info available.
#9 0x0000000000000001 in ?? ()
No symbol table info available.
#10 0x000000006c6fc277 in ?? ()
No symbol table info available.
#11 0x00000000014adf50 in ?? ()
No symbol table info available.
#12 0x00000000014adf68 in ?? ()
No symbol table info available.
#13 0x00007ffff7a58031 in ?? ()
No symbol table info available.
#14 0x0000000000003a98 in ?? ()
No symbol table info available.
#15 0x00000000014adf50 in ?? ()
--Type <RET> for more, q to quit, c to continue without paging--
No symbol table info available.
#16 0x000000006c6fc277 in ?? ()
No symbol table info available.
#17 0x0000000000000002 in ?? ()
No symbol table info available.
#18 0x0000000000000000 in ?? ()
No symbol table info available.

Thread 5 (LWP 6198):
#0 0x00007ffff71dbae7 in ?? ()
No symbol table info available.
#1 0x00000000014c8cf0 in ?? ()
No symbol table info available.
#2 0x00000000014c8cf0 in ?? ()
No symbol table info available.
#3 0x0000000000000002 in ?? ()
No symbol table info available.
#4 0xffffffff00000001 in ?? ()
No symbol table info available.
#5 0x00000000014c6c10 in ?? ()
No symbol table info available.
#6 0x00007ffff7a871ce in ?? ()
No symbol table info available.
#7 0x0000000000000000 in ?? ()
No symbol table info available.

Thread 4 (LWP 6197):
#0 0x00007ffff71dbae7 in ?? ()
No symbol table info available.
#1 0x00000000014b5f50 in ?? ()
No symbol table info available.
#2 0x00000000014b5f50 in ?? ()
No symbol table info available.
--Type <RET> for more, q to quit, c to continue without paging--
#3 0x0000000000000002 in ?? ()
No symbol table info available.
#4 0xffffffff00000001 in ?? ()
No symbol table info available.
#5 0x00000000014b7180 in ?? ()
No symbol table info available.
#6 0x00007ffff7a871ce in ?? ()
No symbol table info available.
#7 0xffffffffffffffa0 in ?? ()
No symbol table info available.
#8 0x00000001ffffa0e0 in ?? ()
No symbol table info available.
#9 0xffffffff7fffffff in ?? ()
No symbol table info available.
#10 0x5ac9915a61af7400 in ?? ()
No symbol table info available.
#11 0x0000000000000000 in ?? ()
No symbol table info available.

Thread 3 (LWP 6196):
#0 0x00007ffff7d910a5 in ?? ()
No symbol table info available.
#1 0x00007fffe7da2280 in ?? ()
No symbol table info available.
#2 0x0000000000000000 in ?? ()
No symbol table info available.

Thread 1 (LWP 6185):
#0 0x000000084d564d08 in ?? ()
No symbol table info available.
#1 0x0000000000aa8615 in ?? ()
No symbol table info available.
#2 0x00000000016deb00 in ?? ()
--Type <RET> for more, q to quit, c to continue without paging--
No symbol table info available.
#3 0x00000000012d4460 in ?? ()
No symbol table info available.
#4 0x00000000016deb00 in ?? ()
No symbol table info available.
#5 0x00000000012cf550 in ?? ()
No symbol table info available.
#6 0x000000000000009c in ?? ()
No symbol table info available.
#7 0x0000009c0001faa4 in ?? ()
No symbol table info available.
#8 0x0000000000000000 in ?? ()
No symbol table info available.
(gdb) quit

Last edited by _Lutz_; 10-12-2019 at 06:49 AM.
_Lutz_ no ha iniciado sesión   Reply With Quote
Old 10-23-2019, 07:19 AM   #5
_Enio_
Marquis
 
_Enio_'s Avatar
 
Join Date: Aug 2007
Location: Germany
Posts: 1,851
_Enio_ will become famous soon enough
Default

Not really useful info in there.

Regarding rolauncher, i remember it could crash related to issues with themes, can you try to disable any special effects and themes? Also can you run ldd on rolauncher and paste its output here?
Also try to run the game executable directly, just to see if it crashes or just produces some error.
__________________
Fix the Marksman subclass: Suggestion
_Enio_ no ha iniciado sesión   Reply With Quote
Old 10-27-2019, 01:29 PM   #6
_Lutz_
Pledge
 
Join Date: Jan 2011
Posts: 10
_Lutz_ is on a distinguished road
Default

$ ldd -v /usr/local/regnum/rolauncher
not a dynamic executable

I have 2 pc, here.. with fedora, 29 and 30, regnum don't start.
the fedora 29, is not a fresh installation, I upgraded system since fedora 26 and worked till 28
the pc with fedora 30, it's fresh install on nvme (i had ssd with fedora 28), the theme is dark breeze (kde), i tryed on gnome with adwaita (default), no success also

to play i need to plug old ssd card with fedora 28.. sad
_Lutz_ no ha iniciado sesión   Reply With Quote
Old 10-28-2019, 06:57 PM   #7
_Enio_
Marquis
 
_Enio_'s Avatar
 
Join Date: Aug 2007
Location: Germany
Posts: 1,851
_Enio_ will become famous soon enough
Default

Quote:
Originally Posted by _Lutz_ View Post
$ ldd -v /usr/local/regnum/rolauncher
not a dynamic executable

I have 2 pc, here.. with fedora, 29 and 30, regnum don't start.
the fedora 29, is not a fresh installation, I upgraded system since fedora 26 and worked till 28
the pc with fedora 30, it's fresh install on nvme (i had ssd with fedora 28), the theme is dark breeze (kde), i tryed on gnome with adwaita (default), no success also

to play i need to plug old ssd card with fedora 28.. sad

I see, can you try
Code:
strace  -o strace.log -Tfe trace=openat,open ./rolauncher
, put it to i.e. pastebin and put a link here or in a pm? Maybe we can find out what its trying to load just before it crashes.
__________________
Fix the Marksman subclass: Suggestion
_Enio_ no ha iniciado sesión   Reply With Quote
Old 10-29-2019, 03:31 AM   #8
_Lutz_
Pledge
 
Join Date: Jan 2011
Posts: 10
_Lutz_ is on a distinguished road
Default

I did this command in both OS

strace on fedora 30
https://pastebin.com/yuCE1fyd

strace on fedora 28
https://pastebin.com/zD9rGx1U

on fedora 28 I closed after load login window

maybe some issue with fonts?
_Lutz_ no ha iniciado sesión   Reply With Quote
Old 10-29-2019, 09:22 AM   #9
_Enio_
Marquis
 
_Enio_'s Avatar
 
Join Date: Aug 2007
Location: Germany
Posts: 1,851
_Enio_ will become famous soon enough
Default

Quote:
Originally Posted by _Lutz_ View Post
I did this command in both OS

strace on fedora 30
https://pastebin.com/yuCE1fyd

strace on fedora 28
https://pastebin.com/zD9rGx1U

on fedora 28 I closed after load login window

maybe some issue with fonts?

Very nice you did both, it looks definitely like some issue with themes, not some missing library.

See if there are more settings regarding that.

I.e. on cinnamon i can set default fonts + sizes, theme for window borders, mouse pointer, controls, desktop elements separately (all set to adwaita). And try disable all effects, all that visual candy.


Edit: I just read that with new gnome they added a new adwaita theme, so it could well be there are problems with it. Try to get some older theme, maybe you can download the old adwaita and use it on fedora 30 for a test.
__________________
Fix the Marksman subclass: Suggestion
_Enio_ no ha iniciado sesión   Reply With Quote
Old 10-29-2019, 05:23 PM   #10
_Lutz_
Pledge
 
Join Date: Jan 2011
Posts: 10
_Lutz_ is on a distinguished road
Default

I found the problem... [font configs on fedora 29/30]

I did a hard work with fonts on this system, and I configured to get best font rendering ever, but I copy my entire home to new installation.

1st I test renaming the files ~/.fonts ~/.fonts.conf and ~/.config/fontconfig/fonts.conf I think the file ~/.fonts.conf is decrapted, not sure about that

but the real problem was in ~/.config/fontconfig/fonts.conf, after relogin, system created new one with few things and all worked. If I use old file.. regnum not load, I didnt check which exactly block config making game crash. My fonts rendering didnt changed

I instaled others gtk-2 and gtk-3 themes also, but wasnt the problem, now all work with gnome default

on kde/gnome i dont use antialising/hint configs by display manager (using system default).

Any1 with Fedora 29/30, check font configs

Thank you very much for help Enio and give me some light about that.
_Lutz_ no ha iniciado sesión   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved