Go Back   Champions of Regnum > English > Technical Support > Linux

Linux Technical issues under Linux platform

Reply
 
Thread Tools Display Modes
Old 12-20-2006, 12:44 AM   #1
jimmio1992
Pledge
 
Join Date: Dec 2006
Posts: 2
jimmio1992 is on a distinguished road
Question Cannot Open OpenAL error??

Sadly, I can't hear any sounds whatsoever out of this wonderful game. I use SuSe Linux 10.1, and, no luck. Any suggestions? Thanks.
jimmio1992 no ha iniciado sesión   Reply With Quote
Old 12-20-2006, 01:03 AM   #2
surak
Legend
 
surak's Avatar
 
Join Date: Mar 2006
Location: Oslo
Posts: 2,172
surak has a spectacular aura aboutsurak has a spectacular aura about
Default

You need to install the openal package from your linux distribution.
__________________
Surak Remember... this is just a game! - Xephandor existe y Miriya es su profeta!
surak no ha iniciado sesión   Reply With Quote
Old 12-20-2006, 05:42 AM   #3
jimmio1992
Pledge
 
Join Date: Dec 2006
Posts: 2
jimmio1992 is on a distinguished road
Default So, pop in the correct Disc?

So, pop in the correct Disc?
jimmio1992 no ha iniciado sesión   Reply With Quote
Old 12-20-2006, 11:47 AM   #4
surak
Legend
 
surak's Avatar
 
Join Date: Mar 2006
Location: Oslo
Posts: 2,172
surak has a spectacular aura aboutsurak has a spectacular aura about
Default

Sorry, what do you mean?
__________________
Surak Remember... this is just a game! - Xephandor existe y Miriya es su profeta!
surak no ha iniciado sesión   Reply With Quote
Old 12-20-2006, 04:04 PM   #5
lvviera
Master
 
Join Date: Oct 2006
Location: part of the "holas" tribe
Posts: 250
lvviera is on a distinguished road
Default

As far as I know it doesn't come with the install cds (at least not in suse 9.1). Unzip this file and put it in /usr/lib (as root)

Surak: Si le entendí pregunta si con meter el disco correcto se arregla.
Attached Files
File Type: zip libopenal.so.zip (96.6 KB, 49 views)
lvviera no ha iniciado sesión   Reply With Quote
Old 12-20-2006, 06:38 PM   #6
ArcticWolf
Duke
 
ArcticWolf's Avatar
 
Join Date: Nov 2006
Location: 0x00CAFE
Posts: 3,631
ArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of light
Default

How to fix the sound on Linux (at least in Ubuntu):

Method #1 (Seldon_SL way):

Open a console and type gedit.
Add the following to the file:

# Contains user settings for OpenAL
# Goes in ~/.openalrc

# Use ALSA (valid: sdl, native, alsa)
(define devices '(native))


Save it as .openalrc on your home directory.

Method #2 (amuchamu way)

Download the file: link to the file.
Unzip the file to your home directory.

Open a console and type sudo cp /home/yourhomedirectory/libopenal.so /usr/lib/libopenal.so.

Maybe you should restart your computer for the changes to take effect.

(Credits to Seldon_SL and amuchamu. Translated by me)


http://www.regnumonline.com.ar/forum...t=libopenal.so
__________________
I don't have a solution, but I admire the problem.
ArcticWolf no ha iniciado sesión   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved