Go Back   Champions of Regnum > English > Technical Support > Linux

Linux Technical issues under Linux platform

Reply
 
Thread Tools Display Modes
Old 01-04-2007, 01:18 AM   #1
jura
Pledge
 
Join Date: Dec 2006
Posts: 4
jura is on a distinguished road
Default BadCursor

Hi, I got another 'crash after start' issue.
Game crashes around intro with

Code:
[RenderizerGL][renderizer_gl_x11.cpp(236)] BadCursor (invalid Cursor parameter)
My gfx card is Radeon 9100 with opensource radeon drivers.
Back trace follows
Code:
libs/libcore_client.so(_ZN10ClientBase14save_backtraceEv+0x7e) [0xb7d6954e]
libs/libcore_client.so(_ZN10ClientBase12client_crashEi+0x17) [0xb7d69857]
[0xb7f2a420]
/usr/lib/xorg/modules/dri/r200_dri.so [0xb67d3a1a]
/usr/lib/xorg/modules/dri/r200_dri.so(_ae_loopback_array_elt+0xe6) [0xb673c4e6]
/usr/lib/xorg/modules/dri/r200_dri.so [0xb686acf3]
/usr/lib/xorg/modules/dri/r200_dri.so(_tnl_DrawArrays+0x103) [0xb686b1a3]
libs/libopengl_api.so(_ZN8Engine3D12RenderizerGL22render_surface_elementEPNS_10RenderList14SurfaceElementEPNS_25ObjectRenderingParametersE+0xe51) [0xb7739331]
libs/libopengl_api.so(_ZN8Engine3D12RenderizerGL11render_meshEPNS_4MeshEP8Matrix4D+0xd9) [0xb77165f9]
libs/libopengl_api.so(_ZN8Engine3D12RenderizerGL15render_gui_meshEffPNS_4MeshEPKSt6vectorI10BitmapBaseSaIS4_EEPKS3_I13StringElementSaIS9_EEf+0xfd) [0xb771678d]
libs/libgui_extension.so(_ZN3GUI16Drawable_GUIMesh15render_internalEv+0xd9) [0xb7917b09]
libs/libgui.so(_ZN3GUI8Drawable6renderEv+0x36) [0xb79f7fa6]
libs/libgui.so(_ZN3GUI6Widget11draw_signalENS_9AreaCoordE+0x197) [0xb79ccda7]
libs/libgui.so(_ZN3GUI6Widget11draw_signalENS_9AreaCoordE+0x1dd) [0xb79ccded]
libs/libgui.so(_ZN3GUI6Widget11draw_signalEv+0x83) [0xb79cd0d3]
libs/libcommon_entities.so(_ZN13DisplayEntity15show_next_frameEv+0x3d) [0xb7ba7fad]
libs/libregnum_client.so(_ZN10GameClient7iterateEv+0x42) [0xb7ef9ff2]
libs/libcore_client.so(_ZN8MainLoop7iterateEv+0x28) [0xb7d79568]
./game(main+0x47) [0x8048b67]
/lib/libc.so.6(__libc_start_main+0xd8) [0xb706d7c8]
./game(__gxx_personality_v0+0x61) [0x8048a81]
jura no ha iniciado sesión   Reply With Quote
Old 01-04-2007, 06:47 PM   #2
Freejack
Pledge
 
Join Date: Dec 2006
Posts: 8
Freejack is on a distinguished road
Default

What version of Linux are you running? Also version of X? Video Card and Driver?
Freejack no ha iniciado sesión   Reply With Quote
Old 01-04-2007, 11:53 PM   #3
jura
Pledge
 
Join Date: Dec 2006
Posts: 4
jura is on a distinguished road
Default

Code:
X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: UNKNOWN
Current Operating System: Linux banshee 2.6.19-ARCH #1 SMP PREEMPT Tue Dec 12 12:47:42 CET 2006 i686
Build Date: 25 December 2006
I got ATi radeon 9100 with open source drivers as I've said before.
jura no ha iniciado sesión   Reply With Quote
Old 01-05-2007, 12:18 AM   #4
surak
Legend
 
surak's Avatar
 
Join Date: Mar 2006
Location: Oslo
Posts: 2,172
surak has a spectacular aura aboutsurak has a spectacular aura about
Default

The linux client was not tested on ATI, you should try the closed source drivers.
__________________
Surak Remember... this is just a game! - Xephandor existe y Miriya es su profeta!
surak no ha iniciado sesión   Reply With Quote
Old 01-05-2007, 12:24 AM   #5
jura
Pledge
 
Join Date: Dec 2006
Posts: 4
jura is on a distinguished road
Default

So .. no luck for me, closed source drivers doesn't work with my chip [it's R200].
jura no ha iniciado sesión   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved