Go Back   Champions of Regnum > English > Technical Support > Linux

Linux Technical issues under Linux platform

Reply
 
Thread Tools Display Modes
Old 12-31-2006, 08:08 PM   #1
brokndodge
Pledge
 
Join Date: Dec 2006
Posts: 1
brokndodge is on a distinguished road
Default game crashes after start

rolauncher updates the game fine, when i click play the game switches resolution to 800x600 then crashes. the log.txt had this to say:

Code:
[RenderizerGL][renderizer_gl_x11.cpp(158)] X Server vendor: The X.Org Foundation
[RenderizerGL][renderizer_gl_x11.cpp(162)] X Server release: 7.1.1
[RenderizerGL][renderizer_gl.cpp(388)] Got a 16 bit visual with a 16 bit depth buffer
[RenderizerGL][renderizer_gl.cpp(408)] OpenGL vendor: Keith Whitwell
[RenderizerGL][renderizer_gl.cpp(409)] OpenGL renderer: Mesa DRI i810 20050821
[RenderizerGL][renderizer_gl.cpp(410)] OpenGL version: 1.2 Mesa 6.5.1
[RenderizerGL][renderizer_gl_extensions_loader.cpp(202)] Detected OpenGL extensions: GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture, GL_ARB_texture_compression, GL_ARB_texture_env_add, GL_ARB_texture_env_combine, GL_ARB_texture_rectangle, GL_EXT_draw_range_elements, GL_EXT_separate_specular_color, GL_EXT_stencil_wrap, GL_EXT_texture_edge_clamp, GL_EXT_texture_lod_bias, GL_SGIS_generate_mipmap, GL_SGIS_texture_lod
[EventImportBase][event_import_base.cpp(80)] Toplevel widget not assigned
[EventImportBase][event_import_base.cpp(80)] Toplevel widget not assigned
[EventImportBase][event_import_base.cpp(80)] Toplevel widget not assigned
[EntitySystem][entity_system.cpp(95)] Entity system ready to shutdown
[Game][game_client.cpp(641)] Exiting Game
err_log.txt
Code:
[GameClient][game_client.cpp(597)] Needed OpenGL extensions not found:

S3TC textures (GL_EXT_texture_compression_s3tc)
S3TC textures (GL_S3_s3tc)


If you know your video card support this capabilities, 
try updating your video drivers to the last available version.
[Game][game_client.cpp(499)] Engine3D::Renderizer::get_active_renderizer()->finish_graphics_system()
here is system.nfo:

Code:
[CPU]
- Vendor Name: GenuineIntel
- Model Name: INTEL Pentium-III
- Family: 6
- Model: 8
- Stepping: 10
- Feature: 3
- Os Support: 0
- Checks: 15

[GPU]
 - OpenGL Support: 1
 - GPU Info: Mesa DRI i810 20050821
is there anything else that i should post to help troubleshoot?
brokndodge no ha iniciado sesión   Reply With Quote
Old 01-01-2007, 02:10 PM   #2
tWalker
Pledge
 
Join Date: Dec 2006
Location: Germany
Posts: 8
tWalker is on a distinguished road
Default

sad thing is that this is not a crash, but the game aborts because of some missing features on your system.

the intel graphics driver you use is hardware accelerated but is missing s3c texture compression (there are patent issues with that and open source i believe)

you may check if you can use the driver provided by intel or you try to install a newer mesa version. the only other way around is buying another graphic card from nvidia or ati.

http://www.burghardt.pl/wiki/articles/s3tc_in_debian describes a hack, but i dont know if it will work with your hardware
tWalker no ha iniciado sesión   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved