English

Go Back   Champions of Regnum > Español > Soporte Técnico > Linux

Linux Problemas técnicos bajo la plataforma Linux

Reply
 
Thread Tools Display Modes
Old 09-19-2016, 08:36 PM   #1
Arnanvs
Pledge
 
Arnanvs's Avatar
 
Join Date: Dec 2008
Location: Puerto Montt, Chile
Posts: 4
Arnanvs is on a distinguished road
Default ¿libpng12?

Hola!

Desde hace mucho que no uso linux y ando bastante perdido con todo, así que me vendría bien una mano.

Hace un rato instale debian (stretch 64 bits) y luego de configurar algunas cosas, el regnum. Resulta que al ejecutar el launcher me dió un error de violación de segmento que mirando otros hilos corregí (¿?) cambiando el tema por defecto que me ofrece gnome. Luego me pidió la típica clave de autorización y luego de introducirla todosederrumbo.mp3

El error que me da es el siguiente:

$ ./rolauncher
./rolauncher: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Bueno según se ve me pide libpng12 pero la cuestión es que en los repositorios de debian veo que la versión que trae es libpng16. Entonces, ¿Cual sería el procedimiento correcto para solucionar esto? o ¿Alguna idea?.
__________________
Jyu Viole Grace Tirador, Pentagram Brujo, Phantaminum Barbaro,
Dekraton Caballero, Arnanus Conjurador, Kaizen Blitz Cazador

Genei Ryodan (Aguante Juppon)
Arnanvs no ha iniciado sesión   Reply With Quote
Old 09-19-2016, 09:09 PM   #2
andres81
Count
 
Join Date: Sep 2008
Posts: 1,709
andres81 is on a distinguished road
Default

libpng12 es libpng version 1.2.x que se lanzo en 2004 creo.
En fin es una libreria obsoleta de hace 12 años o más
http://www.libpng.org/pub/png/libpng.html
Quote:
Those whose apps depend on the older API need not panic, however (for now); libpng 1.2.x continues to get security fixes, as has 1.0.x for well over a decade. (Greg no longer bothers to list either series here; enough's enough, folks. Update those apps now!)
Me imagino que por eso ya no se incluye más en la version actual de Debian, pero puedes intentar instalar el paquete libpng12 de la ultima version de Debian (siempre que aún tenga soporte y reciba actualizaciones) https://packages.debian.org/search?keywords=libpng
andres81 no ha iniciado sesión   Reply With Quote
Old 09-21-2016, 02:10 PM   #3
keyjay
Baron
 
Join Date: Dec 2014
Posts: 646
keyjay is on a distinguished road
Default

Con instalar la librería debería ser suficiente:

Quote:
sudo apt-get install libpng12-0
Dudo que sea una "librería obsoleta" y porque por lo que veo, si se encuentra en oldstable (wheezy), stable (jessie) y unstable (sid), obviamente no en el iso de la instalación (donde solo ponen lo que es libre y necesario), pero si en sus repos.
keyjay no ha iniciado sesión   Reply With Quote
Old 10-03-2016, 09:59 PM   #4
Arnanvs
Pledge
 
Arnanvs's Avatar
 
Join Date: Dec 2008
Location: Puerto Montt, Chile
Posts: 4
Arnanvs is on a distinguished road
Default

Bueno estuve fuera del país unos días asi que no había podido ver esto. Ayer con algo de tiempo revise nuevamente y encontre una solución a mi problema.

Como comentaba anteriormente en los repositorios de debian stretch (testing) no existe libpng12 sino que la versión existente es libpng16. Lo mismo pasa en sid (unstable) (aunque la página diga otra cosa). En el caso de Jessie (stable) si se encuentra libpng12, y si bien se puede hacer uso de los repositorios de la versión estable para instalar libpng12 faltan otras cosas aún para hacer funcionar bien el audio. La solución más sencilla que encontré fue agregar los siguientes repositorios al /etc/apt/sources.list

deb http://debian.c3sl.ufpr.br/debian/ testing-updates main contrib non-free
deb-src http://debian.c3sl.ufpr.br/debian/ testing-updates main contrib non-free

En estos repositorios se encuentra lo necesario para poder ejecutar el juego con normalidad para los usuarios de debian stretch.
__________________
Jyu Viole Grace Tirador, Pentagram Brujo, Phantaminum Barbaro,
Dekraton Caballero, Arnanus Conjurador, Kaizen Blitz Cazador

Genei Ryodan (Aguante Juppon)
Arnanvs no ha iniciado sesión   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved