Go Back   Champions of Regnum > English > Technical Support > Linux

Linux Technical issues under Linux platform

Reply
 
Thread Tools Display Modes
Old 08-12-2016, 12:47 PM   #21
_Enio_
Marquis
 
_Enio_'s Avatar
 
Join Date: Aug 2007
Location: Germany
Posts: 1,843
_Enio_ will become famous soon enough
Default

Quote:
Originally Posted by Elanor View Post
I don't think OpenGL or the Intel driver have nothing to do with this, though. I think is either something pointing to a wrong location for the textures within the binary (ius there a reason why you guys don't provide sourceces?) or missing libraries of some sort.
Well, i think these are just followup errors on a bad "initialization" here, first line in your error.log:
Code:
[11/08/2016 14:29:35] [RenderizerGL][renderizer_gl_x11.cpp(353)] BadMatch (invalid parameter attributes)
That RenderizerGL is a regnum module, it probably gets some values it cannot handle. But thats all just guesses.

Edit: This is the comparison of our OpenGL extensions, the left side is what i have and you do not, right side you have and i do not.
Code:
[enio@thinkpad Desktop]$ diff -y --suppress-common-lines sorted_enio.txt sorted_siggy.txt 
                                  >
                                  >    GL_AMD_performance_monitor,
GL_ARB_query_buffer_object,                      <
GL_ARB_robust_buffer_access_behavior,                  <
GL_ARB_shader_precision,                      <
GL_ARB_stencil_texturing,                      <
GL_ARB_texture_stencil8,                      <
GL_EXT_texture_compression_s3tc,                  <
                                  >    GL_INTEL_performance_query,
GL_KHR_robust_buffer_access_behavior,                  <
Afaik, s3tc texture compression is needed by regnum. It seems it can be enabled somehow. Check out this thread: http://askubuntu.com/questions/56379...intel-graphics

Edit2: This is quite old (2011) "Using the external libtxc-dxtn library for S3TC compression. Mesa will attempt to load it if it exists, and provide full S3TC support. This is available in xorg-edgers, at least."

Edit3:
Code:
[enio@thinkpad Desktop]$ locate libtxc
/usr/lib/libtxc_dxtn.so
Maybe you just need to install that one.
__________________
Fix the Marksman subclass: Suggestion

Last edited by _Enio_; 08-12-2016 at 01:12 PM.
_Enio_ no ha iniciado sesión   Reply With Quote
Old 08-12-2016, 01:15 PM   #22
Elanor
Pledge
 
Join Date: Aug 2007
Posts: 11
Elanor is on a distinguished road
Default

I can see the missing intel extension

Quote:
[siggy@alnair regnum]$ glxinfo | grep GL_INTEL_performance
GL_INTEL_performance_query, GL_KHR_context_flush_control, GL_KHR_debug,
and the AMD missing extension as well

Quote:
[siggy@alnair regnum]$ glxinfo | grep GL_AMD_performance_monitor
GL_AMD_draw_buffers_blend, GL_AMD_performance_monitor,
Is there a list of pre requisites? just wanna make sure i have all i need.
Elanor no ha iniciado sesión   Reply With Quote
Old 08-12-2016, 01:18 PM   #23
_Enio_
Marquis
 
_Enio_'s Avatar
 
Join Date: Aug 2007
Location: Germany
Posts: 1,843
_Enio_ will become famous soon enough
Default

Sorry, i was just editing my post without refreshing the page.

tl;dr from my previous post is:

Install the libtxc-dxtn library for S3TC compression support and try regnum again.
__________________
Fix the Marksman subclass: Suggestion
_Enio_ no ha iniciado sesión   Reply With Quote
Old 08-12-2016, 01:18 PM   #24
Elanor
Pledge
 
Join Date: Aug 2007
Posts: 11
Elanor is on a distinguished road
Default

I have this too:
Quote:
/usr/lib64/libtxc_dxtn.so
Elanor no ha iniciado sesión   Reply With Quote
Old 08-12-2016, 01:23 PM   #25
_Enio_
Marquis
 
_Enio_'s Avatar
 
Join Date: Aug 2007
Location: Germany
Posts: 1,843
_Enio_ will become famous soon enough
Default

You might also need to install "driconf" and let me quote someone else "A window appears with "Direct Rendering Settings". Go to the "Image Quality" tab. Set "Enable S3TC texture compression even if software support is not available" to yes"
__________________
Fix the Marksman subclass: Suggestion
_Enio_ no ha iniciado sesión   Reply With Quote
Old 08-12-2016, 01:24 PM   #26
Elanor
Pledge
 
Join Date: Aug 2007
Posts: 11
Elanor is on a distinguished road
Default

so i reinstalled the package libtxc_dxtn.x86_64 and now it's working properly.
Thanks a lot for the help. I was kinda surpirsed it wasn't working properly. Maybe a note about prerequisites for linux would be a good idea.

EDIT: It speaks volumes of the quality of Regnum that this is the first time i've required any kind of support to make it work since i first install it.
Elanor no ha iniciado sesión   Reply With Quote
Old 08-12-2016, 01:29 PM   #27
_Enio_
Marquis
 
_Enio_'s Avatar
 
Join Date: Aug 2007
Location: Germany
Posts: 1,843
_Enio_ will become famous soon enough
Default

Quote:
Originally Posted by Elanor View Post
so i reinstalled the package libtxc_dxtn.x86_64 and now it's working properly.
This is good news. I think this is mainly an issue with distributions. Many seem to come shipping with it when installing mesa stuff.

Anyways, glad it works now.
__________________
Fix the Marksman subclass: Suggestion
_Enio_ no ha iniciado sesión   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved