Go Back   Champions of Regnum > English > Technical Support > Linux

Linux Technical issues under Linux platform

Reply
 
Thread Tools Display Modes
Old 11-03-2018, 10:52 AM   #1
Belegond
Pledge
 
Join Date: Sep 2012
Posts: 2
Belegond is on a distinguished road
Default RO Launcher still crashes at launch ...

Hi everybody,

this is starting to get really frustrating. I have upgraded my computer about 2 months ago and made a clean install of Kubuntu.

I reinstalled RO at the same time.

Since then it crashes at launch. I don't even get to the part where you have to accept the license agreement.

It is the segmentation fault. So after searching for 2 months through the different forums, search engines etc ... I give up and ask for help.

I have even tried to install the game through Steam, to no avail.

This is my current configuration:

OS: Kubuntu 18.04 LTS

- i5-3470
- Nvidia Geforce GTX 680
- 8 GB of RAM
- graphic driver is: nvidia-driver-390

I can paste the log output if it's any use.

Thanks for any help.
Belegond no ha iniciado sesión   Reply With Quote
Old 11-06-2018, 01:28 PM   #2
forum2658a5c
Pledge
 
Join Date: May 2018
Posts: 5
forum2658a5c is on a distinguished road
Default

Quote:
Originally Posted by Belegond View Post
Hi everybody,

this is starting to get really frustrating. I have upgraded my computer about 2 months ago and made a clean install of Kubuntu.

I reinstalled RO at the same time.

Since then it crashes at launch. I don't even get to the part where you have to accept the license agreement.

It is the segmentation fault. So after searching for 2 months through the different forums, search engines etc ... I give up and ask for help.

I have even tried to install the game through Steam, to no avail.

This is my current configuration:

OS: Kubuntu 18.04 LTS

- i5-3470
- Nvidia Geforce GTX 680
- 8 GB of RAM
- graphic driver is: nvidia-driver-390

I can paste the log output if it's any use.
Thanks for any help.
Start it from terminal, show us the console output. [S]Is any library missing? If I remember correctly, regnum used old version of libpng, which is was not available in repositories and you had to copy it from package from older release.[/S] Or is it regular crash? There used to be crashes related to GTK library and theming. Try setting default gtk2 theme and default icon theme.

(What tag do I use for strikethrough text? Can't figure this out )
forum2658a5c no ha iniciado sesión   Reply With Quote
Old 11-14-2018, 02:03 PM   #3
Belegond
Pledge
 
Join Date: Sep 2012
Posts: 2
Belegond is on a distinguished road
Unhappy

Thank you for your reply. I have launched from the terminal and got this error:

~/regnum$ ./rolauncher
libpng warning: Application jmp_buf size changed
Erreur de segmentation (core dumped)

Apparently there is an issue with some buffer.

This is after a clean install.
Belegond no ha iniciado sesión   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved