Go Back   Champions of Regnum > English > Technical Support > Linux

Linux Technical issues under Linux platform

Reply
 
Thread Tools Display Modes
Old 07-25-2016, 04:33 PM   #21
ZericOfGa
Pledge
 
Join Date: Apr 2009
Posts: 41
ZericOfGa is on a distinguished road
Default

Hmm...

Code:
./rolauncher: error while loading shared libraries: libjpeg.so.62: cannot open shared object file: No such file or directory
Is it still supposed to require the old version? I tried reinstalling but for some reason its not creating the new .62 libraries..

Tried to do a link again and i got:
Code:
./rolauncher: /usr/lib/libjpeg.so.62: version `LIBJPEG_6.2' not found (required by ./rolauncher)
ZericOfGa no ha iniciado sesión   Reply With Quote
Old 07-25-2016, 04:39 PM   #22
_Enio_
Marquis
 
_Enio_'s Avatar
 
Join Date: Aug 2007
Location: Germany
Posts: 1,847
_Enio_ will become famous soon enough
Default

Quote:
Originally Posted by ZericOfGa View Post
Is it still supposed to require the old version? I tried reinstalling but for some reason its not creating the new .62 libraries..
I had to explicitely get an old version (libjpeg6-turbo package on arch linux) so i guess yes. Tried symlinking before too and got a similar error.

Nice to see you too, I sometimes play on Alsius RA nowadays
__________________
Fix the Marksman subclass: Suggestion
_Enio_ no ha iniciado sesión   Reply With Quote
Old 07-25-2016, 04:45 PM   #23
Adrian
NGD·Studios
 
Adrian's Avatar
 
Join Date: May 2007
Location: Wien, Österreich
Posts: 3,252
Adrian will become famous soon enoughAdrian will become famous soon enough
Default

Quote:
Originally Posted by ZericOfGa View Post
Is it still supposed to require the old version? I tried reinstalling but for some reason its not creating the new .62 libraries..
No, it shouldn't. Anyway, I don't quite understand what you mean with "it's not creating".

As Enio said, getting somehow (be it compiling or with a package) libjpeg62 should suffice.
__________________
Adrian no ha iniciado sesión   Reply With Quote
Old 07-25-2016, 04:46 PM   #24
ZericOfGa
Pledge
 
Join Date: Apr 2009
Posts: 41
ZericOfGa is on a distinguished road
Default

Quote:
Originally Posted by _Enio_ View Post
I had to explicitely get an old version (libjpeg6-turbo package on arch linux) so i guess yes. Tried symlinking before too and got a similar error.

Nice to see you too, I sometimes play on Alsius RA nowadays
I'll try to install from source again.. see if that works.

Figured you'd moved. Try not to hit me too hard, play conj on Syrtis/Ra sometimes :P
ZericOfGa no ha iniciado sesión   Reply With Quote
Old 07-25-2016, 04:49 PM   #25
ZericOfGa
Pledge
 
Join Date: Apr 2009
Posts: 41
ZericOfGa is on a distinguished road
Default

Crap. Looks like the version I downloaded from the site was updated, so it doesn't reinstall the .62 libs. Looking for source. Will get back to you when I've got something to report.
ZericOfGa no ha iniciado sesión   Reply With Quote
Old 07-25-2016, 05:06 PM   #26
ZericOfGa
Pledge
 
Join Date: Apr 2009
Posts: 41
ZericOfGa is on a distinguished road
Default

Wow Ok never thought I'd say this but.. saved by.. Steam?!

I don't even use Steam, but at one point installed it.. and due to its level of bloat, it installs all it's own libraries needed. I copied their libjpeg.so.62 file from:

/home/username/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libjpeg.so.62

to:

/usr/lib

and hey presto! Launcher opens, game updated and works. Thanks for the help. To be honest I'm surprised, first time I ever really got support with this game :d

Since you're on a roll.. any chance you could figure out how I can pay for xim from Africa w/o credit/debit cards? Bitcoin would be nice ^^
ZericOfGa no ha iniciado sesión   Reply With Quote
Old 07-25-2016, 06:20 PM   #27
Adrian
NGD·Studios
 
Adrian's Avatar
 
Join Date: May 2007
Location: Wien, Österreich
Posts: 3,252
Adrian will become famous soon enoughAdrian will become famous soon enough
Default

Quote:
Originally Posted by ZericOfGa View Post
...
I'm glad it worked! And not so that you had bad experiences with our support in the past.

About the Bitcoins, we've been thinking about it!
__________________
Adrian no ha iniciado sesión   Reply With Quote
Old 07-25-2016, 06:47 PM   #28
ZericOfGa
Pledge
 
Join Date: Apr 2009
Posts: 41
ZericOfGa is on a distinguished road
Default

Quote:
Originally Posted by Adrian View Post
I'm glad it worked! And not so that you had bad experiences with our support in the past.

About the Bitcoins, we've been thinking about it!
Well it's a shame thinking is only half the process

I'm from the US but there is definitely a market for your game here in Africa. If people are able to get the initial files from a place locally and maintain updates themselves, the data costs wouldn't scare them too much.. but they wouldn't have any way to pay for xim. Given RO is an older game a lot of newer hardware is drawing your clientele away.. but here they're still using hardware from the time of when Regnum was new, so they can't handle the new games.

Just thought you'd like to know :P
ZericOfGa no ha iniciado sesión   Reply With Quote
Old 07-25-2016, 10:13 PM   #29
_Enio_
Marquis
 
_Enio_'s Avatar
 
Join Date: Aug 2007
Location: Germany
Posts: 1,847
_Enio_ will become famous soon enough
Default

Quote:
Originally Posted by ZericOfGa View Post
I copied their libjpeg.so.62 file [...] and hey presto! Launcher opens, game updated and works. Thanks for the help. To be honest I'm surprised, first time I ever really got support with this game :d

Hey thats good news, actually yes, it could make stuff more seamless if those 2 needed libs (libpng/libjpeg) could be shipped in regnum folder for linux. Shouldnt be any issues for i386 / x86_64 and rolauncher would look there first before checking library path.
__________________
Fix the Marksman subclass: Suggestion
_Enio_ no ha iniciado sesión   Reply With Quote
Old 07-26-2016, 10:40 PM   #30
_Enio_
Marquis
 
_Enio_'s Avatar
 
Join Date: Aug 2007
Location: Germany
Posts: 1,847
_Enio_ will become famous soon enough
Default

I was just thinking - wouldn't it be easier to statically link those 2 libs into the rolauncher binary? this would prevent issues with installing the dependencies - which might be difficult on some distros/for some less experienced users.
__________________
Fix the Marksman subclass: Suggestion
_Enio_ no ha iniciado sesión   Reply With Quote
Reply

Tags
core dump, rolauncher, segmentation fault

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved