English

Go Back   Champions of Regnum > Español > Soporte Técnico > Linux

Linux Problemas técnicos bajo la plataforma Linux

Reply
 
Thread Tools Display Modes
Old 11-10-2007, 04:47 PM   #1
neronet
Pledge
 
Join Date: May 2007
Posts: 22
neronet is on a distinguished road
Default Problema con tarjeta Intel Mobile.

Uso debian lenny (testing)

kernel - 2.6.22-2-686
tarjeta grafica - Intel Corporation Mobile GM965/GL960

Si tengo aceleracion 3d, pero al ejecutar el juego y poner el login me sale el mensaje de que la tarjeta no es compatible, esta anticuada...
En consola no me da nigun tipo de error. E probado con los drivers intel y i810, con el mismo resultado en ambos.

El archivo de /live/system.nfo
[CPU]
- Vendor Name: GenuineIntel
- Model Name: Unknown
- Family: 6
- Model: 15
- Stepping: 13
- Feature: 7
- Os Support: 0
- Checks: 15

[GPU]
- OpenGL Support: 0
- Shader Model: Fixed Pipeline
- GPU Info:



La salida de glxinfo | grep direct
direct rendering: Yes

La salida de glxinfo | grep version
server glx version string: 1.2
client glx version string: 1.4
GLX version: 1.2
OpenGL version string: 1.4 Mesa 7.0.1


Me han comentado si puede ser tema de las extensiones, pero no se muy bien de que va eso. Con otros juegos que usan opengl si funcionan, ademas con el SO que traia el portatil de fabrica el RO funciona en directx y opengl.
Pues eso, a que podria ser devido, o por donde podria seguir buscando?.

Gracias

Last edited by neronet; 12-07-2007 at 03:19 AM.
neronet no ha iniciado sesión   Reply With Quote
Old 12-07-2007, 03:24 AM   #2
x7iBiT
Pledge
 
x7iBiT's Avatar
 
Join Date: Jun 2007
Location: Syrtis
Posts: 46
x7iBiT is on a distinguished road
Default

Post Up!!!




Ahora en serio... ¿Alguien más tiene problemas con el X3100?
__________________
  • Warlok: Elfo del Bosque Brujo Lvl. 50
  • Lekter: Semielfo Tirador Lvl 38
  • Xzibit: Alturian Caballero Lvl. 37
x7iBiT no ha iniciado sesión   Reply With Quote
Old 12-07-2007, 12:16 PM   #3
neronet
Pledge
 
Join Date: May 2007
Posts: 22
neronet is on a distinguished road
Default

Bueno pues probe lo que dice en este post:

http://regnumonline.com.ar/forum/showthread.php?t=15740

Ejecutar driconf e activar la compresion de texturas S3TC, lo cual ya
entra al lanzador del juego y se actualiza, pero en el momento de
ejecutar el juego, sale el puntero del raton y se cierra, mostrando este
error en la terminal:

intel_region_data: Assertion `dst_offset + dstx + width + (dsty + height - 1) * dst->pitch * dst->cpp <= dst->pitch * dst->cpp * dst->height' failed.
Saving backtrace to crash_backtrace_3752.log

y el contedido del log es:
Code:
libs/libcore_client.so(_ZN10ClientBase14save_backtraceEv+0x7e) [0xb7d6539e]
libs/libcore_client.so(_ZN10ClientBase12client_crashEi+0x17) [0xb7d65727]
[0xffffe420]
[0xffffe410]
/lib/i686/cmov/libc.so.6(gsignal+0x55) [0xb6fa07f5]
/lib/i686/cmov/libc.so.6(abort+0x101) [0xb6fa2181]
/lib/i686/cmov/libc.so.6(__assert_fail+0xee) [0xb6f99b6e]
/usr/lib/dri/i965_dri.so [0xb6a84b5c]
/usr/lib/dri/i965_dri.so(intel_miptree_image_data+0xed) [0xb6a83ebd]
/usr/lib/dri/i965_dri.so(intel_finalize_mipmap_tree+0x1f2) [0xb6a8be62]
/usr/lib/dri/i965_dri.so [0xb6abd02f]
/usr/lib/dri/i965_dri.so(brw_validate_state+0x261) [0xb6aa79a1]
/usr/lib/dri/i965_dri.so [0xb6a9bda7]
/usr/lib/dri/i965_dri.so [0xb6a9c0da]
/usr/lib/dri/i965_dri.so(brw_draw_prims+0xa5) [0xb6a9c5d5]
/usr/lib/dri/i965_dri.so [0xb6b38389]
libs/libopengl_api.so(_ZN8Engine3D12RenderizerGL22render_surface_elementEPNS_10RenderList14SurfaceElementEPNS_25ObjectRenderingParametersE+0xfa5) [0xb76ba185]
libs/libopengl_api.so(_ZN8Engine3D12RenderizerGL11render_meshEPNS_4MeshEP8Matrix4D+0xe6) [0xb768e306]
libs/libopengl_api.so(_ZN8Engine3D12RenderizerGL15render_gui_meshEffPNS_4MeshEPKSt6vectorI10BitmapBaseSaIS4_EEPKS3_I13StringElementSaIS9_EEf+0x18e) [0xb768e87e]
libs/libgui_extension.so(_ZN3GUI16Drawable_GUIMesh15render_internalEv+0xdc) [0xb78b1d0c]
libs/libgui.so(_ZN3GUI8Drawable6renderEv+0x36) [0xb79abe56]
libs/libgui.so(_ZN3GUI6Widget11draw_signalENS_9AreaCoordE+0x138) [0xb797c8e8]
libs/libgui.so(_ZN3GUI6Widget11draw_signalENS_9AreaCoordE+0x17e) [0xb797c92e]
libs/libgui.so(_ZN3GUI6Widget11draw_signalENS_9AreaCoordE+0x17e) [0xb797c92e]
libs/libgui.so(_ZN3GUI6Widget11draw_signalENS_9AreaCoordE+0x17e) [0xb797c92e]
libs/libgui.so(_ZN3GUI6Widget11draw_signalEv+0x83) [0xb797cc23]
libs/libcommon_entities.so(_ZN13DisplayEntity15show_next_frameEv+0x81) [0xb7b796a1]
libs/libregnum_client.so(_ZN10GameClient7iterateEv+0x42) [0xb7f138e2]
libs/libcore_client.so(_ZN8MainLoop7iterateEv+0x28) [0xb7d77308]
./game(main+0x47) [0x8048b67]
/lib/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb6f8c050]
./game(__gxx_personality_v0+0x61) [0x8048a81]
Probe ejecutando en distintas resoluciones, modo seguro, sincronizando recursos. Tambien probe ejecutar el juego con:

MALLOC_CHECK_=0 ./rolauncher
MALLOC_CHECK=0 ./rolauncher
G_SLICE=always-malloc ./rolauncher

pero nada, siempre me da el error.
Bueno ahora por lo menos me da error XD, a ver si alguien me podria ayudar.
neronet no ha iniciado sesión   Reply With Quote
Old 01-16-2008, 12:20 AM   #4
ArcticWolf
Duke
 
ArcticWolf's Avatar
 
Join Date: Nov 2006
Location: 0x00CAFE
Posts: 3,631
ArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of light
Default

Puede ser que al xorg.conf le falten cargar módulos:

Code:
Section "Module"
    Load    "bitmap"
    Load    "ddc"
    Load    "dri"
    Load    "extmod"
    Load    "freetype"
    Load    "glx"
    Load    "int10"
    Load    "vbe"
EndSection
Eso va en el xorg, pero todavía no lo pongas!!! Primero hacé un

Code:
cat /etc/X11/xorg.conf | grep Load
Si te tira resultados, se supone que no es necesario. Si no devuelve nada, editá el archivo como root y reiniciá las X
__________________
I don't have a solution, but I admire the problem.
ArcticWolf no ha iniciado sesión   Reply With Quote
Old 01-21-2008, 03:42 PM   #5
neronet
Pledge
 
Join Date: May 2007
Posts: 22
neronet is on a distinguished road
Default

Bueno, esta solución no a resultado. Pero gracias de todos modos.

En verdad, modificar el xorg.conf de este modo ya lo habia probado, ya que en varios sitios donde busqué sobre como configurar las tarjetas intel en linux me lo indicaba, pero todas en las que indicaban estas modificaciones manuales eran para el driver i810, en el driver que estoy usando, intel que se supone que es mas actual (uso debian lenny), no e notado niguna diferencia poniendo esto en el xorg.conf que sin ponerlo, ya que funciona igual en ambos modos, por lo que entiendo que no es necesario, de todos modos investigare un poco mas en esto.

Saludos.

Last edited by neronet; 01-21-2008 at 04:00 PM.
neronet no ha iniciado sesión   Reply With Quote
Old 01-21-2008, 05:51 PM   #6
ArcticWolf
Duke
 
ArcticWolf's Avatar
 
Join Date: Nov 2006
Location: 0x00CAFE
Posts: 3,631
ArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of light
Default

En mi -pobre- experiencia personal, lo único que podría hacer en este caso es recomendarte que instales los drivers propietarios sin el apt-get. Lo que tiene lenny (y por eso sigo con etch) es que todavía hay muchas cosas que al no estar probadas a fondo siguen fallando... Ojo, hacer un downgrade tampoco lo veo como la solución, pero podés probar con eso.

Fijate, por último, si en el xorg.conf aparece esto:


Code:
...
Section "Device"
...
Option "XAANoOffscreenPixmaps" "True"
...
EndSection
...
Section "Extensions"
Option "Composite" "Enable"
EndSection
...
Los puntos suspensivos indican opciones u otras líneas en el medio.
__________________
I don't have a solution, but I admire the problem.
ArcticWolf no ha iniciado sesión   Reply With Quote
Old 01-21-2008, 06:16 PM   #7
neronet
Pledge
 
Join Date: May 2007
Posts: 22
neronet is on a distinguished road
Default

Propones que compile la ultima versión de los drivers de intel.

http://intellinuxgraphics.org/download.html

Pero esto: Compiling and/or upgrading graphics drivers in Linux is a complex and error-prone task.
Como que tira un poco para atras jeje

Bueno creo que lo mejor será que mi distribuición actualice los drivers, ya que igual el soporte para mi tarjeta abrá mejorado.

En cuanto a esas lineas del xorg.conf, no las tengo.
neronet no ha iniciado sesión   Reply With Quote
Old 01-21-2008, 06:29 PM   #8
sunos
Count
 
sunos's Avatar
 
Join Date: Jan 2007
Location: Rosario
Posts: 1,412
sunos has a spectacular aura aboutsunos has a spectacular aura about
Default

mmm.. si no me confundo eso mismo pasaba en ubuntu hace poco con unas actualizaciones que corrigieron rapido, mmm.. fijate si no tenes algo para updatear :-S , acordate que lenny es inestable y muchas veces no anda del todo bien
__________________
Usuario GNU/linux registrado Nº450915
"Sólo hay un problema con el sentido común: que no es demasiado común" -- Milt Bryce
sunos no ha iniciado sesión   Reply With Quote
Old 01-21-2008, 09:04 PM   #9
x7iBiT
Pledge
 
x7iBiT's Avatar
 
Join Date: Jun 2007
Location: Syrtis
Posts: 46
x7iBiT is on a distinguished road
Default

Quote:
Originally Posted by sunos
mmm.. si no me confundo eso mismo pasaba en ubuntu hace poco con unas actualizaciones que corrigieron rapido, mmm.. fijate si no tenes algo para updatear :-S , acordate que lenny es inestable y muchas veces no anda del todo bien
Lenny no es es más inestable que Ubuntu (más bien es al revés), ya que Ubuntu está basado en la rama inestable de Debian (actualmente Sid).

La rama estable de debian (Etch) tiene versiones bastante viejas (y depuradas) de todo, a costa de tener una estabilidad a prueba de bombas, lo que la hace ideal para montar un servidor o algo así. Para un "usuario de escritorio" no hace falta ni de lejos tanta estabilidad.
__________________
  • Warlok: Elfo del Bosque Brujo Lvl. 50
  • Lekter: Semielfo Tirador Lvl 38
  • Xzibit: Alturian Caballero Lvl. 37
x7iBiT no ha iniciado sesión   Reply With Quote
Old 01-21-2008, 09:29 PM   #10
ArcticWolf
Duke
 
ArcticWolf's Avatar
 
Join Date: Nov 2006
Location: 0x00CAFE
Posts: 3,631
ArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of light
Default

Quote:
Originally Posted by x7iBiT
Lenny no es es más inestable que Ubuntu (más bien es al revés), ya que Ubuntu está basado en la rama inestable de Debian (actualmente Sid).

La rama estable de debian (Etch) tiene versiones bastante viejas (y depuradas) de todo, a costa de tener una estabilidad a prueba de bombas, lo que la hace ideal para montar un servidor o algo así. Para un "usuario de escritorio" no hace falta ni de lejos tanta estabilidad.
Yo uso Etch porque se fehacientemente que funciona bien y no necesito lo último (tampoco mi hardware es de lo más moderno). Me conformo con algo estable, con drivers que funcionen sin problemas y me de lo justo y necesario. Actualmente, la única razón por la que compraría un equipo más potente y nuevo sería sólo para poder jugar al Regnum.

Con respecto a Syd, en realidad Debian es un conjunto de agregados y un par de modificaciones, la mayoría de soft non-free y customizado para que agarre en lo más nuevo o se vea "bonito". Ubuntu tiene muchas "ayudas al usuario" que lo hacen perfecto para iniciarse en linux y usarlo como un ambiente de escritorio, pero reportó varios problemas para correr muchos juegos (incluye el Wolfenstein ET, DEFCON, OpenArena y por supuesto Regnum) por su inestable ciclo de modificaciones de seis meses entre distros.

Los errores más comunes se dan en la libc, supongo que la modifican específicamente ellos para optimizar una o dos cosas, pero causa problemas en innumerables programas más. Es por esa misma razón que decidí volver a Etch después de casi un año y medio en Ubuntu.
__________________
I don't have a solution, but I admire the problem.
ArcticWolf no ha iniciado sesión   Reply With Quote
Reply

Tags
linux intel

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved